SCCM és a WebDAV probléma

A minap SCCM ügynököket szerettem volna kiszórni néhány gépre, de csodálkozva láttam, hogy a telepítés nem sikerül. Leellenőriztem minden feltételt, amely a kliensek telepítéséhez szükséges – elvileg semmi semi hiányzott. Végül a célgépek C:\Windows\CCMSetup mappa ccmsetup.log-jában nyomra akadtam: “<![LOG[Failed to correctly receive a WEBDAV HTTP request.]LOG]!>”.

Az SCCM működéséhez szükség van IIS-re, továbbá az IIS-hez le kell tölteni  a WebDAV-ot a Microsoft download oldaláról. A letöltés után, de még az SCCM telepítés előtt konfigurálni kell ezen oldalon leírtak alapján. Én ezt meg is tettem, ám valahogy ez a beállítás “elállítódott”. Amikor az IIS konzolon meg szerettem volna nyitni a WebDAV részt, ilyen üzenet fogadott.

image

Jó volna tudni, hogy miért, mert a hivatkozott sorban korántsem volt dupla bejegyzés, de még a <clear  /> sor beírása sem segített rajtam. Viszont a helyes sorrendű komponens újrarakás megoldotta a helyzetet. Vagyis:

  1. Eltávolítottam az SCCM konzollal a Management Point Site System-et.- ez használja a WebDAV-ot.
  2. A Server Manager “Remove Role Service” funkciójával kikapcsoltam a WebDAV-ot. Kaptam egy felhívást a rendszer újraindítására.
  3. Újraindítás.
  4. WebDAV újbóli felrakása (Add Role Service) WebDAV beállítások ellenőrzése – érdekes módon minden beállítás, ami az SCCM-hez kellett, megvolt.
  5. SCCM Managment Point hozzáadása a Site System szerepkörökhöz.
  6. Ennyi – az SCCM ügynökök már kúsztak is fel a gépekre.

Advertisements